def save_file(self, outputfilename=None):
outputfilename = outputfilename or self.image_filename
self.file.read(outputfilename)
or even
def save_file(self, outputfilename=None):
self.file.read(outputfilename or self.image_filename)
This may be nothing with one variable, but if you have, let's say, 5, this makes code easier to read, in my opinion.