Warning-used as the name of the previous parameter rather than as part of the selector

后端 未结 3 742
一个人的身影
一个人的身影 2021-02-15 13:13

I am using a function in a class as below

- (void) uploadMorePic:(NSDictionary *) MuliPics: (NSData *)file  

It shows the warning - Muli

相关标签:
3条回答
  • 2021-02-15 13:24

    Because you haven't separately specified the parameter name and the selector definition. Basically, you're missing a space and/or a word. Try:

    -(void)uploadMorePictures:(NSDictionary *)pics withFile:(NSData *)file
    

    Which separately names and specifies both parameters to the method.

    0 讨论(0)
  • 2021-02-15 13:24

    @dpassage 's answer is nice。

    The function name of objective-c is not like C or C++, it has some parameter and the same num of description of parameter name。 In your case, you did not set your first parameter name or you did not set your description of your second parameter name.

    What @dpassage said was the first condition, missing first parameter name.

    0 讨论(0)
  • 2021-02-15 13:34

    It's a poor message, but it's because you didn't provide a name for the first parameter to your method. Try this:

    -(void)uploadMorePic:(NSDictionary *)dict muliPics:(NSData *)file
    

    I also fixed a style issue; the name of the second part of the method name should start with a lower-case letter. I don't know what your method does, so you may be able to come up with a better name.

    0 讨论(0)
提交回复
热议问题