Given this method, does this represent some egregious stylistic or semantic faux pas:
private double translateSlider(int sliderVal) { switch (sliderVal) {
Nope, what you have is fine. You could also do this as a formula (sliderVal < 5 ? (1.0 - 0.1 * sliderVal) : 1.0) or use a Map, but what you have is fine.
sliderVal < 5 ? (1.0 - 0.1 * sliderVal) : 1.0
Map