Given this method, does this represent some egregious stylistic or semantic faux pas:
private double translateSlider(int sliderVal) {
switch (sliderVal) {
I think that what you have written is perfectly fine. I also don't see any readability issue with having multiple return statements.
I would always prefer to return from the point in the code when I know to return and this will avoid running logic below the return.
There can be an argument for having a single return point for debugging and logging. But, in your code, there is no issue of debugging and logging if we use it. It is very simple and readable the way you wrote.