What is the rationale behind this naming convention?
I don\'t see any benefit. The extra prefix just pollutes the API.
My thinking is inline with Konrad\'s respo
If you consider the two "best-practice-aphorisms"
clarity is king
and
noise is bad
there is a conflict between these. The question is: when does clarity become noise?
For me it more noisy (but equally clear) to write Person person = new PersonImpl() than IPerson person = new Person().
Person person = new PersonImpl()
IPerson person = new Person()