I guess that most factory-like methods start with create
. But why are they called \"create\"? Why not \"make\", \"produce\", \"build\", \"generate\" or something el
Personally I like instantiate
and instantiateWith
, but that's just because of my Unity and Objective C experiences. Naming conventions inside the Unity engine seem to revolve around the word instantiate
to create an instance via a factory method, and Objective C seems to like with
to indicate what the parameter/s are. This only really works well if the method is in the class that is going to be instantiated though (and in languages that allow constructor overloading, this isn't so much of a 'thing').
Just plain old Objective C's initWith
is also a good'un!