I guess that most factory-like methods start with create
. But why are they called \"create\"? Why not \"make\", \"produce\", \"build\", \"generate\" or something el
I'd call it UriFactory.Create()
Where,
UriFactory
is the name of the class type which is provides method(s) that create Uri
instances.
and Create()
method is overloaded for as many as variations you have in your specs.
public static class UriFactory
{
//Default Creator
public static UriType Create()
{
}
//An overload for Create()
public static UriType Create(someArgs)
{
}
}