During code review I discovered many places of our C# code that looks like this:
if(IsValid()) { return true; } else { return false; }
I would also just say "return IsValid();" I think you're 100% correct in doing so