Usually when we want to initialize NSMutableArray
we use:
NSMutableArray *mArr = [[NSMutableArray alloc] initWithObjects: @\"one\", @\"two\", @\"thr
But I think the second way to be way more readable
Personally, I find it more confusing, and even more confusing since you are using mutableCopy
as if it was a property. Correct, correct, but totally misleading IMHO.
Why not just take advantage of inheritance?
NSMutableArray *ma = [NSMutableArray arrayWithObjects:@"foo", @"bar", nil];
Sometimes collections which are mutable by default would be of more use. * sigh *