I want to store an list of key value pair lists in a lightweight structure. This seems too cumbersome. What\'s better? Does List
For clarity I would wrap your KeyValuePair
into something shorter, e.g. StringPair
and also define a shorthand for a list of StringPair
. This will shorten your syntax and help readability IMHO.
public class StringPair : KeyValuePair { }
public class StringPairList : List { }
..
var jaggedList = new List();