I have always written my boolean expressions like this:
if (!isValid) { // code }
But my new employer insists on the following style:
It was discussed for C# several hours ago.
The false == isValid construct is a leftover from C-world, where compiler would allow you to do assignments in if statement. I believe Java compilers will warn you in such case.
false == isValid
if
Overall, second option is too verbose.