I\'m often having code written as follows
try: self.title = item.title().content.string except AttributeError, e: self.title = None
How about a two-liner?
Denser, less readable, but you really save two keypresses!