I know this is a subjective question, but I\'m always curious about best-practices in coding style. ReSharper 4.5 is giving me a warning for the keyword \"base\" before bas
The only time you should use base.MethodCall();
is when you have an overridden method of the same name in the child class, but you actually want to call the method in the parent.
For all other cases, just use MethodCall();
.
Keywords like this
and base
do not make the code more readable and should be avoided for all cases unless they are necessary--such as in the case I described above.