For those of you who name you member variables with no special notation like m_foo or foo_, how do you name parameters to your ctors and setters?>
m_foo
foo_
I name the actual members with trailing underscores, so I do this:
Foo(int bar) : bar_(bar) { }
The reason is so I can use getter functions without anything like getBar() (bar() is better).