Coming from a C# background the naming convention for variables and method names are usually either camelCase or PascalCase:
David Goodger (in "Code Like a Pythonista" here) describes the PEP 8 recommendations as follows:
joined_lower for functions, methods, attributes, variables
joined_lower
joined_lower or ALL_CAPS for constants
ALL_CAPS
StudlyCaps for classes
StudlyCaps
camelCase only to conform to pre-existing conventions
camelCase