I\'m writing a django model that allows my site to have coupons.
Coupons can have three types: lifetime account voucher, certain period of months voucher, certain numb
I think spreading this over a few lines is fine - this makes it easier to maintain if there were more attributes to test in the future. Using len
or sum
feels a bit too obfuscated
# Ensure that only one of these values is set
true_count = 0
true_count += bool(self.months)
true_count += bool(self.dollars)
true_count += bool(self.lifetime)