As far as I know there are three ways of finding out if an object is an Array
by isArray function if implemented
isArray
Array.isArray()
Unless it was proven that the former has significant performance benefits and my app required every last ounce of speed I would go for the latter.
The reason is readability, pure and simple.