Ok, consider this common idiom that most of us have used many times (I assume):
class FooBarDictionary { private Dictionary fooBars;
It sort of depends why you're doing it - the idiom is one I've seen be called memoization, caching, initialisation on demand, create on first use. Normally I call the method "ensureFoo" rather than "GetOrCreate"