Since the naming of a unit test method makes its purpose more meaningful, is it necessary to add a summary to a unit test method?
Example:
///
An XML comment is totally unnecessary if you have a descriptive method name. And it's a must for unit-test methods.
You're already on the right track having a descriptive test method name. (Many agile and TDD practitioners believe that a test method should include "should", e.g. as shown in link text this blog post.
Personally, I like method names like this:
MyClass_OnInvalidInput_ShouldThrowFormatException()
But that's merely my personal preference.