I find this form
doLotOfStuff();
if (condition) {
return foo;
}
return bar;
to be more readable than the one with the else, it's less code and more intuitive if you think about it as a guard statement as in Fowler's Refactoring.
Question about multiple return points.