Typically you will find STL code like this:
for (SomeClass::SomeContainer::iterator Iter = m_SomeMemberContainerVar.begin(); Iter != m_SomeMemberContainerVar.end
I find the second option more readable, as you don't end up with one giant line. However, Ferruccio brings up a good point about the scope.