I\'m inclined to write if statements by using logical negation operator:
if (!p) some_code();
Some people around me tend to use explicit co
Use (0 == p) or (p == 0) for readability. That ! is easier to overlook at first glance than == 0
(0 == p)
(p == 0)
!
== 0
Use (0 == p) if you have a habit of ignoring compiler warnings, and want to know when you use = rather than ==.