I frequently find myself creating classes which use this form (A):
abstract class Animal { public void Walk() { // TODO: do something before walking /
I'm not sure if there is a standard naming convention for this. Besides WalkInternal, other alternatives might be DoWalk or WalkImpl.
WalkInternal
DoWalk
WalkImpl