I have a tuple foo
which contains something I don\'t care about and something I do.
foo = (something_i_dont_need, something_i_need)
<
I've been using _
for over a decade. It is much more readable, especially when extracting more than one value:
_, _, name, _, _, city, _ = whatever
Even with only one variable, the other way forces humans readers to count if they want to truly understand the code, and more likely their eyes are just going to pass over it.
With the underscores, you can leverage the human brain's pattern matching abilities a little better. Probably a small thing, but every little bit helps when you're debugging. :)