Given the 2 toString() implementations below, which one is preferred:
toString()
public String toString(){ return \"{a:\"+ a + \", b:\" + b + \", c: \"
Since Java 1.5, simple one line concatenation with "+" and StringBuilder.append() generate exactly the same bytecode.
So for the sake of code readability, use "+".
2 exceptions :